roundcube login

#1
hallo und wunderschönes neues Jahr :)

bei meiner serverkonfiguration funktioniert alles einwandfrei bis auf den webinterface login von roundcube.

aufrufbar ist roundecube mittels https://ip/webmail

beim login, egal mit welcher mail kommt folgende fehlermeldung:
Ungültige Anfrage! Es wurden keine Daten gespeichert.

ich tappe im dunkeln - weiß jemand eine lösung?

=======

und eine weitere frage hätte ich noch, mein provider stellt auf eine neue ip adresse bis ende des jahres um, muss ich diese einfach nur im controlpanel unter system->serverkonfiguration anpassen?

unter server ip adressen habe ich die neue bereits hinzugefügt aber die domains werden noch immer zur alten ip aufgelöst.

besten dank!
 
#3
wo kann ich dies einsehen?

in der serverkonfiguration (ispconfig) ist der pfad:
/var/vmail/[domain]/[localpart]
und soweit ich dies beurteilen kann stimmt dieser auch, im handbuch habe ich leider nichts gefunden was mir mit meinem verständis weiterhelfen kann.

lg
 

nowayback

Well-Known Member
#4
wurde denn der remote user für roundcube angelegt?
hat der user die benötigten rechte?
wurden die erforderlichen plugins aktiviert?
 
#5
1) ja wurde er

2) hier die rechte - meiner meinung nach ja:
Server functions
E-Mail Benutzer Funktionen
E-Mail Alias Funktionen
E-Mail Spamfilter Benutzer Funktionen
E-Mail Spamfilter Richtlinien Funktionen
E-Mail Fetchmail Funktionen
Mail spamfilter whitelist functions
Mail spamfilter blacklist functions
E-Mail Benutzer Filter Funktionen
Kunden Funktionen

3)folgende plugins sind aktiviert:
// List of active plugins (in plugins/ directory)
$config['plugins'] = array(
'archive',
'zipdownload',
'jqueryui',
'ispconfig3_account',
'ispconfig3_autoreply',
'ispconfig3_autoselect',
'ispconfig3_pass',
'ispconfig3_spam',
'ispconfig3_fetchmail',
'ispconfig3_filter',
'ispconfig3_forward',
ispconfig3_wblist,
);
im plugins ordner sind dann folgende enthalten:
acl additional_message_headers database_attachments enigma help http_authentication jqueryui managesieve new_user_identity newmail_notifier password squirrelmail_usercopy zipdownload

hier bin ich etwas überfragt was die konfiguration angeht - bin jetzt zur überprüfung nach diesem tutorial hier gegangen: https://www.howtoforge.com/tutorial/ispconfig-3-roundcube-plugins-on-debian-stretch/

in /var/log/roundcube/errors habe ich folgende errors:

[07-Jan-2019 17:33:58 UTC] PHP Warning: session_start(): Failed to read session data: user (path: /var/lib/php/sessions) in /usr/share/roundcube/program/lib/Roundcube/rcube_session.php on line 117
[07-Jan-2019 17:33:58 UTC] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin_api.php on line 406
[07-Jan-2019 17:33:58 UTC] PHP Warning: Use of undefined constant E2 - assumed 'E2' (this will throw an Error in a future version of PHP) in /usr/share/roundcube/program/lib/Roundcube/rcube_utils.php on line 259
 

Till

Administrator
#6
Schau mal bitte in die globale apache error.log Datei, ob dort noch weitere Fehler drin stehen beim roundcube login. Hast Du auf Deinem server vielleichtr eine neuere PHP version installiert mit der RoundCube möglicherweise nicht klar kommt?
 
#7
im apache error log kommt bei roundcube dies hier vor:

[Tue Jan 08 18:30:21.542974 2019] [proxy_fcgi:error] [pid 27094] [client *.*.*.*:56228] AH01071: Got error 'PHP message: PHP Warning: Declaration of rcmail::get_instance($env = '') should be compatible with rcube::get_instance($mode = 0, $env = '') in /usr/share/roundcube/program/include/rcmail.php on line 30\nPHP message: PHP Warning: Use of undefined constant ispconfig3_wblist - assumed 'ispconfig3_wblist' (this will throw an Error in a future version of PHP) in /etc/roundcube/config.inc.php on line 87\n'r

die ports ändern sich immer wieder:
56228
56253
25546

ansonsten ist standardmäßig in der systemkonfiguration->web->php php5 drinnen, installiert sind allerdings noch php7.1 und php7.2

guten abend :)
 

Till

Administrator
#8
Also das PHP unter dem das Roundcube läuft ist meiner meinung nach kein PHP 5.6, ich denke mal Du hast aus versehen das Standard PHP auf PHP 7.2 geändert. Benutz mal den update-alternatives befehl um php und php-fpm auf 5.6 zurück zu stellen und dann mal apache neu starten.
 
#9
hier der auszug:

/var/log/apache2# update-alternatives --config php
There are 2 choices for the alternative php (providing /usr/bin/php).

Selection Path Priority Status
------------------------------------------------------------
0 /usr/bin/php7.2 72 auto mode
* 1 /usr/bin/php5 50 manual mode
2 /usr/bin/php7.2 72 manual mode

hatte ich nämlich wirklich mal aus versehen und dann ging eine site nicht mehr daraufhin gings wieder auf 5 zurück :)
 
#11
/var/log/apache2# update-alternatives --config php-cgi
There are 2 choices for the alternative php-cgi (providing /usr/bin/php-cgi).

Selection Path Priority Status
------------------------------------------------------------
0 /usr/bin/php-cgi7.2 72 auto mode
1 /usr/bin/php-cgi7.2 72 manual mode
* 2 /usr/bin/php5-cgi 50 manual mode
 

Till

Administrator
#12
Du kannst ja folgendes mal versuchen, lege in /usr/share/roundcube/ eine info.php Datei ab die den phpinfo() Befehl ausführt und rufe dann die url .../webmail/info.php ab und schau welche PHP version das ergibt. Vielleicht bin ich auch auf einer komplett falschen spur, aber damit wissen wir sicher welche PHP version tatsächlich verwendet wird.
 
#13
so bekomme ich aufs erste eigenartigerweise ein "File not Found".

phpinfo(); in der index.php in /usr/share/roundcube/ führt auch zu keinem ergebnis.

@Till
du hast recht - habe jetzt die index.php auf index_2.php und die info.php in index.php umbenannt und siehe da PHP Version 7.2.13 ist aktiv

wie kann ich das anpassen? :)
 
Zuletzt bearbeitet:

Till

Administrator
#18
Hmm, ein apache server aber roundcube läuft auf php-fpm, normal läuft das auf mod_php. Ich vermute mal da hast Du irgend was am setup umgebaut, mpm_prefork gegen anderes mpm getauscht oder so?
 

Werbung

Top