Problem mit Typo3 auf ISPConfig

Doc Lowy

New Member
Hallo all.

Ich habe einen neuen ISPConfig-Server aufgesetzt.
Debian 9, ISPConfig 3.1.13, aufgesetzt nach https://www.howtoforge.com/tutorial/perfect-server-debian-9-stretch-apache-bind-dovecot-ispconfig-3-1/

Nun habe ich per 'APS Installationsassistent' einem Kunden das 'Typo3' (Version 8.7.17-65) installiert und unter 'Optionen' safe_mode = off, memory_limit = 256MB und max_execution_time = 300 eingetragen.
Leider erhalte ich folgende Fehlermeldungen im error.log;
Unter Fast-CGI: [fcgid:warn] [pid 27679] [client nnn.nnn.nnn.nnn:61916] mod_fcgid: stderr: PHP Fatal error: Allowed memory size of 2097152 bytes exhausted (tried to allocate 36864 bytes)
Unter PHP-FPM: [proxy_fcgi:error] [pid 31974] [client nnn.nnn.nnn.nnn:62259] AH01071: Got error 'PHP message: PHP Fatal error: Allowed memory size of 2097152 bytes exhausted (tried to allocate 36864 bytes)

Was ich bisher als Lösung (vergeblich) versucht habe:
Erhöhung des memory_limit auf 3072

Hat irgendjemand das Typo3 irgendwie ans Laufen bekommen?

Viele Grüße, Wolfgang
 

nowayback

Well-Known Member
Prinzipiell ist deine Idee richtig, was aber fehlt ist die Angabe in welcher Größe... also 3072 ist etwas anders als 3072M
Vielleicht kontrollierst du deine Einstellungen nochmal und schaust, wie es angegeben werden muss... ich dächte es wäre 256M gewesen anstatt 256MB
Deine Meldung sagt übrigends aus, dass 2048 kilobytes zu wenig sind... daher ist davon auszugehen das deine 256MB nicht ziehen
 

Doc Lowy

New Member
ich dachte, ich stelle das Ganze so ein, wie in den Einstellungen beschrieben; also 'memory_limit = 256 MB'.
Ich habe aber schon mit allen möglichen Kombinationen getestet. Mit '268435456', '256MB', 256 MB', '256 M'. Wird in der phpinfo() auch immer korrekt angezeigt, aber es kommt immer dieser error...
 

Till

Administrator
PHP möchte schon die richtige Schreibweise für seine Optionen haben, und die ist:

memory_limit = 256M
 

Doc Lowy

New Member
Ok... Ich habe nun mit 'memory_limit = 256M' versucht:

Mit 'PHP-FPM':
[Mon Feb 11 08:30:18.809072 2019] [proxy_fcgi:error] [pid 4701] [client nnn.nnn.nnn.nnn:56040] AH01071: Got error 'PHP message: PHP Fatal error: Uncaught UnexpectedValueException: LocalConfiguration invalid. in /var/www/clients/client14/web12/web/typo3/sysext/core/Classes/Configuration/ConfigurationManager.php:303\nStack trace:\n#0 /var/www/clients/client14/web12/web/typo3/sysext/core/Classes/Core/Bootstrap.php(505): TYPO3\\CMS\\Core\\Configuration\\ConfigurationManager->exportConfiguration()\n#1 /var/www/clients/client14/web12/web/typo3/sysext/core/Classes/Core/Bootstrap.php(398): TYPO3\\CMS\\Core\\Core\\Bootstrap->populateLocalConfiguration()\n#2 /var/www/clients/client14/web12/web/typo3/sysext/core/Classes/Core/Bootstrap.php(172): TYPO3\\CMS\\Core\\Core\\Bootstrap->loadConfigurationAndInitialize()\n#3 /var/www/clients/client14/web12/web/typo3/sysext/frontend/Classes/Http/Application.php(69): TYPO3\\CMS\\Core\\Core\\Bootstrap->configure()\n#4 /var/www/clients/client14/web12/web/typo3/sysext/frontend/Resources/Private/Php/frontend.php(23): TYPO3\\CMS\\Frontend\\Http\\Application->__construct(Object(Composer\\Autoload\\ClassLoader))\n#5 /var/www...\n'

Mit 'Fast-CGI':
[Mon Feb 11 08:32:12.360035 2019] [fcgid:warn] [pid 4992] [client nnn.nnn.nnn.nnn:56201] mod_fcgid: stderr: PHP Fatal error: Uncaught UnexpectedValueException: LocalConfiguration invalid. in /var/www/clients/client14/web12/web/typo3/sysext/core/Classes/Configuration/ConfigurationManager.php:303
[Mon Feb 11 08:32:12.360060 2019] [fcgid:warn] [pid 4992] [client nnn.nnn.nnn.nnn:56201] mod_fcgid: stderr: Stack trace:
[Mon Feb 11 08:32:12.360063 2019] [fcgid:warn] [pid 4992] [client nnn.nnn.nnn.nnn:56201] mod_fcgid: stderr: #0 /var/www/clients/client14/web12/web/typo3/sysext/core/Classes/Core/Bootstrap.php(505): TYPO3\\CMS\\Core\\Configuration\\ConfigurationManager->exportConfiguration()
[Mon Feb 11 08:32:12.360065 2019] [fcgid:warn] [pid 4992] [client nnn.nnn.nnn.nnn:56201] mod_fcgid: stderr: #1 /var/www/clients/client14/web12/web/typo3/sysext/core/Classes/Core/Bootstrap.php(398): TYPO3\\CMS\\Core\\Core\\Bootstrap->populateLocalConfiguration()
[Mon Feb 11 08:32:12.360068 2019] [fcgid:warn] [pid 4992] [client nnn.nnn.nnn.nnn:56201] mod_fcgid: stderr: #2 /var/www/clients/client14/web12/web/typo3/sysext/core/Classes/Core/Bootstrap.php(172): TYPO3\\CMS\\Core\\Core\\Bootstrap->loadConfigurationAndInitialize()
[Mon Feb 11 08:32:12.360070 2019] [fcgid:warn] [pid 4992] [client nnn.nnn.nnn.nnn:56201] mod_fcgid: stderr: #3 /var/www/clients/client14/web12/web/typo3/sysext/frontend/Classes/Http/Application.php(69): TYPO3\\CMS\\Core\\Core\\Bootstrap->configure()
[Mon Feb 11 08:32:12.360073 2019] [fcgid:warn] [pid 4992] [client nnn.nnn.nnn.nnn:56201] mod_fcgid: stderr: #4 /var/www/clients/client14/web12/web/typo3/sysext/frontend/Resources/Private/Php/frontend.php(23): TYPO3\\CMS\\Frontend\\Http\\Application->__construct(Object(Composer\\Autoload\\ClassLoader))
[Mon Feb 11 08:32:12.360082 2019] [fcgid:warn] [pid 4992] [client nnn.nnn.nnn.nnn:56201] mod_fcgid: stderr: #5 /var/www/clients/client14/web12/web/typo3/s in /var/www/clients/client14/web12/web/typo3/sysext/core/Classes/Configuration/ConfigurationManager.php on line 303
 

Till

Administrator
Die APS Pakete sind nicht von ISPConfig, es kann seind ass nicht alle 100%ig unktionieren. Ich würde ein komplexes CMS wie Typo3 immer klassisch von hand installieren, also upload in die website oder download in die website per shell user und dann den web installer des CMS aufrufen.
 

Doc Lowy

New Member
Achso, ich wusste zwar, dass die APS-Sachen nicht von ISPConfig kommen, ging jedoch davon aus dass sie für ISPConfig verifiziert sind.
Ok, dann werde ich heute abend mal die manuelle Installation versuchen.
 

Werbung

Top