Problem mit Certbot und SSL-Cert für ISPConfig-Panel

leipold

New Member
Hallo!

Nach einer Migration mit dem Migrationsscript von Strato zu einem neuen Hoster erhalte ich nun bei ispconfig_update.sh --force folgende Fehlermeldung:

Code:
Create new ISPConfig SSL certificate (yes,no) [no]: yes
Missing command line flag or config entry for this setting:
Please choose an account
Choices: ['h2929549.stratoserver.net@2021-04-02T18:49:23Z (f71a)', 'h2429980.stratoserver.net@2017-03-08T12:12:42Z (f269)', 'h2778071.stratoserver.net@2021-04-06T02:07:49Z (e3af)', 'community.websilon.de@2022-02-21T15:56:42Z (1c8b)']
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.
Issuing certificate via certbot failed. Please check log files and make sure that your hostname can be verified by letsencrypt
Could not issue letsencrypt certificate, falling back to self-signed.
Ich habe Certbot bereits erfolgreich auf snapd umgestellt. Wie kann ich die alten Stratoaccounts für Certbot entfernen?

Gruß, Holger
 

Till

Administrator
Hallo Holger,

Du musst einen korrekten Hostnamen auf dem servers etzen, also eine Subdomain von einer Deiner eigenen Domains und dieser muss antürlich auch im DNS existieren. Editiere /etc/hosts, /etc/hostname, /etc/mailname, starte den server neu und mach dann nochmal ein ISPConfig Update mit --force Option.
 

leipold

New Member
Hallo Till,

danke für deine Antwort. Aus meiner Sicht passen die Namen. Meine Domain websilon.de löst im DNS auf die Server-IP 89.58.29.49 auf. Der Server heißt community.websilon.de und auch hier wird der Name korrekt auf die selbe IP aufgelöst.
Code:
cat /etc/hosts:

127.0.0.1       localhost.localdomain   localhost
127.0.1.1       community.websilon.de   community

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
Code:
 cat /etc/hostname:
 
 community
Code:
cat /etc/mailname:

community.websilon.de
Trotzdem scheitert das ISPConfig-Update mit der Meldung:
Please choose an account
Choices: ['h2929549.stratoserver.net@2021-04-02T18:49:23Z (f71a)', 'h2429980.stratoserver.net@2017-03-08T12:12:42Z (f269)', 'h2778071.stratoserver.net@2021-04-06T02:07:49Z (e3af)', 'community.websilon.de@2022-02-21T15:56:42Z (1c8b)']

certbot renew --dry-run läuft fehlerfrei über alle restlichen Domains und scheitert schließlich bei der Serverdomain websilon.de. Hier werden insgesamt 21 Zertifikate für ehemalige Domains angefordert, die in ISPConfig längst gelöscht sind.

Gruß, Holger
 

Till

Administrator
Ok, dann hast Du mehrere accounts in certbot erstellt. Du musst alle accounts bis auf einen löschen.
 

leipold

New Member
OK - danke. Ich habe die überflüssigen Accounts gelöscht.
ispconfig_update.sh --force ist jetzt durchgelaufen und ich konnte eines neues Zertifikat erstellen. Jetzt läuft aber leider apache2 nicht mehr. Im Apache error.log finde ich die Meldung:
Certificate and private key community.websilon.de:8080:0 from /usr/local/ispconfig/interface/ssl/ispserver.crt and /usr/local/ispconfig/interface/ssl/ispserver.key do not match.
 

Werbung

Top