Postfix - Störung aus heiterem Himmel

ralphy

New Member
Hallo zusammen, seit ca zwei Wochen bekomme ich keine Emails mehr. Aktuell kann ich auch keine mehr versenden. Der Server steht bei mir Zuhause und wird über eine PFSense 1:1 durgeschleift. (ubuntu 20.04.5 mit neustem ISP_Config). Ich habe einen zweiten Server neu installiert und da rührt sich auch nichts. Habe dan bei Netcup einen VPS gemietet, automatische ISP_Config Installation durchgeführt, leider dass gleiche Problem. Der Server ist jetz seit ca. 6 jahre fehlerfrei gelaufen. Ein Blacklist Test war negativ.
Über MXLookup habe ich einen SMTP test durchgeführt.
Da wird folgender Fehler angezeigt: "554 5.7.1 <test@mxtoolboxsmtpdiag.com>: Relay access denied [370 ms]".
Aktuell bin ich mit meinem Latein am Ende, vielleicht kennt jemnad das Problem und kann mir helfen.
 

Anhänge

Till

Administrator
Da wird folgender Fehler angezeigt: "554 5.7.1 <test@mxtoolboxsmtpdiag.com>: Relay access denied [370 ms]".
Das ist keine Fehler sondern die Meldung dass der Server korrekt konfiguriert ist und eben kein open relay.

Schau in das mail.log um zu sehen warum Dein Server nicht funktioniert. Es kann auch sein dass z.B. Dein Internet Provider zuhause angefangen hat Port 25 zu blockieren, was viele Provider für Privatkundenanschlüsse machen.
 

ralphy

New Member
Hallo, Danke für die die schnelle Antwort. Das war auch meine Vermutung das die Telekom den Port 25 blockiert. Deshalb habe ich den VPS bei Netcup bestellt und neu aufgesetzt. Alles funktioniert, bis auf die E-Mails. (Ich habe bei der Telekom einen Business Anschluss, im Vertrag wird erlaubt einen Mailserver zu betreiben.)

Folgende Fehler habe ich auf meinem Server Zuhause in der Log Datei gefunden:

Code:
xin postfix/smtpd[736197]: disconnect from unknown[5.34.xxx.xx] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Aug 28 00:00:08 xin dovecot: auth: Warning: auth client 0 disconnected with 1 pending requests: Connection reset by peer
Aug 28 00:00:09 xin postfix/smtpd[739437]: warning: unknown[5.34.xxx.xx]: SASL LOGIN authentication failed: Connection lost to authentication server
 

ralphy

New Member
Das gleiche Problem scheint auch auf dem Testserver bei Netcup zu sein:

Code:
Sep  1 20:42:39 mxa dovecot: imap(admin@olmix.de)<12073><+9hW+qHnJpIAAAAAAAAAAAAAAAAAAAAB>: Logged out in=353 out=2265 deleted=0 expunged=0 trashed=0 hdr_count=0 hdr_bytes=0 body_count=0 body_bytes=0
Sep  1 20:42:44 mxa postfix/smtpd[10392]: connect from unknown[5.34.207.246]
Sep  1 20:42:44 mxa postfix/smtpd[10392]: disconnect from unknown[5.34.207.246] quit=1 commands=1
Sep  1 20:42:45 mxa postfix/smtpd[10995]: warning: unknown[5.34.207.246]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Sep  1 20:42:46 mxa postfix/smtpd[10995]: disconnect from unknown[5.34.207.246] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Sep  1 20:42:52 mxa postfix/smtpd[11842]: connect from unknown[5.34.207.246]
Die IP 5.34.207.246 scheint aus der Ukraine zu sein. Das hier habe ich auch noch gefunden:
 
Zuletzt bearbeitet:

Till

Administrator
Dann hat das in Log nichts mit Deinem Problem zu tun, das ist nur das normale 'rauschen' im Internet :) Verbinde Dich mit Deinem Mailprogramm mit dem Server, geht das oder geht es nicht und wenn es geht, sende eine email an dich selbst, also an die adresse mit der sich Dein mailprogramm verbunden hat.
 

ralphy

New Member
Ich habe die Log Datei geleert und eine EMail an mich gesendet. Intern kann ich E-Mail verschicken. Bekomme aber keine von auserhalb und kann auch keine nach außen senden.
Code:
Sep  2 11:38:21 xin dovecot: master: Dovecot v2.3.7.2 (3c910f64b) starting up for imap, pop3, lmtp (core dumps disabled)
Sep  2 11:38:22 xin postgrey[1490]: Process Backgrounded
Sep  2 11:38:22 xin postgrey[1490]: 2022/09/02-11:38:22 postgrey (type Net::Server::Multiplex) starting! pid(1490)
Sep  2 11:38:22 xin postgrey[1490]: Resolved [localhost]:10023 to [127.0.0.1]:10023, IPv4
Sep  2 11:38:22 xin postgrey[1490]: Binding to TCP port 10023 on host 127.0.0.1 with IPv4
Sep  2 11:38:22 xin postgrey[1490]: Setting gid to "125 125"
Sep  2 11:38:22 xin postgrey[1490]: Setting uid to "118"
Sep  2 11:38:24 xin amavis[1210]: starting. /usr/sbin/amavisd-new at xin.xnet.one amavisd-new-2.11.0 (20160426), Unicode aware, LC_ALL="C", LANG="C.UTF-8"
Sep  2 11:38:25 xin amavis[2054]: Net::Server: Group Not Defined.  Defaulting to EGID '127 127'
Sep  2 11:38:25 xin amavis[2054]: Net::Server: User Not Defined.  Defaulting to EUID '120'
Sep  2 11:38:25 xin amavis[2054]: No $altermime,         not using it
Sep  2 11:38:25 xin amavis[2054]: No ext program for   .lrz, tried: lrzip -q -k -d -o -, lrzcat -q -k
Sep  2 11:38:25 xin amavis[2054]: No ext program for   .rpm, tried: rpm2cpio.pl, rpm2cpio
Sep  2 11:38:25 xin amavis[2054]: No ext program for   .zoo, tried: zoo
Sep  2 11:38:25 xin amavis[2054]: No ext program for   .doc, tried: ripole
Sep  2 11:38:25 xin amavis[2054]: No decoder for       .F   
Sep  2 11:38:25 xin amavis[2054]: No decoder for       .doc
Sep  2 11:38:25 xin amavis[2054]: No decoder for       .lrz
Sep  2 11:38:25 xin amavis[2054]: No decoder for       .zoo
Sep  2 11:38:25 xin amavis[2054]: Using primary internal av scanner code for ClamAV-clamd
Sep  2 11:38:25 xin amavis[2054]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
Sep  2 11:38:26 xin postfix/postfix-script[2100]: warning: symlink leaves directory: /etc/postfix/./smtpd.key
Sep  2 11:38:26 xin postfix/postfix-script[2113]: warning: symlink leaves directory: /etc/postfix/./smtpd.cert
Sep  2 11:38:26 xin postfix/postfix-script[2121]: warning: symlink leaves directory: /etc/postfix/./smtpd.key-le-20210516.bak
Sep  2 11:38:26 xin postfix/postfix-script[2133]: warning: symlink leaves directory: /etc/postfix/./makedefs.out
Sep  2 11:38:26 xin postfix/postfix-script[2141]: warning: symlink leaves directory: /etc/postfix/./smtpd.cert-le-20210516.bak
Sep  2 11:38:26 xin postfix/postfix-script[2315]: starting the Postfix mail system
Sep  2 11:38:26 xin postfix/master[2325]: daemon started -- version 3.4.13, configuration /etc/postfix
Sep  2 11:38:28 xin dovecot: imap-login: Login: user=<xxx@olmix.de>, method=PLAIN, rip=62.216.204.84, lip=10.10.x.x, mpid=2443, session=<bOMAfq7nEaY+2MxU>
Sep  2 11:38:28 xin dovecot: imap-login: Login: user=<xxx@olmix.de>, method=PLAIN, rip=62.216.204.84, lip=10.10.x.x, mpid=2445, session=</OwAfq7nc6Y+2MxU>
Sep  2 11:38:28 xin postfix/smtpd[2446]: connect from unknown[5.34.207.23]
Sep  2 11:38:31 xin postfix/smtpd[2453]: connect from unknown[5.34.207.23]
Sep  2 11:38:34 xin postfix/smtpd[2455]: connect from unknown[5.34.207.23]
Sep  2 11:38:37 xin postfix/smtpd[2446]: warning: unknown[5.34.207.23]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
 

ralphy

New Member
Code:
Sep  2 11:38:38 xin postfix/smtpd[2526]: connect from unknown[5.34.207.23]
Sep  2 11:38:38 xin postfix/smtpd[2650]: connect from unknown[212.70.149.68]
Sep  2 11:38:38 xin postfix/smtpd[2446]: disconnect from unknown[5.34.207.23] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Sep  2 11:38:39 xin postfix/smtpd[2446]: connect from unknown[212.70.149.20]
Sep  2 11:38:40 xin postfix/submission/smtpd[2689]: connect from unknown[192.168.xx.182]
Sep  2 11:38:40 xin postfix/submission/smtpd[2689]: NOQUEUE: filter: RCPT from unknown[192.168.xx.182]: <ralphy@olmix.de>: Sender address triggers FILTER lmtp:[127.0.0.1]:10026; from=<ralpxx@olmix.de> to=<ralpxx@olmix.de> proto=ESMTP helo=<[192.168.xx.182]>
Sep  2 11:38:40 xin postfix/submission/smtpd[2689]: ADAE119A10C3: client=unknown[192.168.xx.182], sasl_method=PLAIN, sasl_username=ralpxx@olmix.de
Sep  2 11:38:40 xin postfix/cleanup[2701]: ADAE119A10C3: message-id=<1eac276e-ab4d-d955-b704-d462d7c096fc@olmix.de>
Sep  2 11:38:40 xin postfix/qmgr[2328]: ADAE119A10C3: from=<ralpxx@olmix.de>, size=631, nrcpt=1 (queue active)
Sep  2 11:38:40 xin postfix/submission/smtpd[2689]: disconnect from unknown[192.168.xx.182] ehlo=2 starttls=1 auth=1 mail=1 rcpt=1 data=1 quit=1 commands=8
Sep  2 11:38:40 xin dovecot: imap-login: Login: user=<ralpxx@olmix.de>, method=PLAIN, rip=192.168.xx.182, lip=10.10.x.x, mpid=2705, TLS, session=<9LLGfq7n1N/AqE22>
Sep  2 11:38:40 xin amavis[2448]: (02448-01) (!)connect to /var/run/clamav/clamd.ctl failed, attempt #1: Can't connect to a UNIX socket /var/run/clamav/clamd.ctl: No such file or directory
Sep  2 11:38:40 xin dovecot: imap(ralpxx@olmix.de)<2705><9LLGfq7n1N/AqE22>: Logged out in=525 out=632 deleted=0 expunged=0 trashed=0 hdr_count=0 hdr_bytes=0 body_count=0 body_bytes=0
Sep  2 11:38:41 xin postfix/smtpd[2707]: connect from unknown[5.34.207.23]
Sep  2 11:38:41 xin amavis[2448]: (02448-01) (!)connect to /var/run/clamav/clamd.ctl failed, attempt #1: Can't connect to a UNIX socket /var/run/clamav/clamd.ctl: No such file or directory
Sep  2 11:38:41 xin amavis[2448]: (02448-01) (!)ClamAV-clamd: All attempts (1) failed connecting to /var/run/clamav/clamd.ctl, retrying (2)
Sep  2 11:38:44 xin postfix/smtpd[2453]: warning: unknown[5.34.207.23]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Sep  2 11:38:44 xin postfix/smtpd[2752]: connect from unknown[5.34.207.23]
Sep  2 11:38:45 xin postfix/smtpd[2453]: disconnect from unknown[5.34.207.23] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Sep  2 11:38:46 xin postfix/smtpd[2650]: warning: unknown[212.70.149.68]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Sep  2 11:38:46 xin postfix/smtpd[2650]: disconnect from unknown[212.70.149.68] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Sep  2 11:38:47 xin postfix/smtpd[2455]: warning: unknown[5.34.207.23]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Sep  2 11:38:47 xin amavis[2448]: (02448-01) (!)connect to /var/run/clamav/clamd.ctl failed, attempt #1: Can't connect to a UNIX socket /var/run/clamav/clamd.ctl: No such file or directory
Sep  2 11:38:47 xin amavis[2448]: (02448-01) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamav/clamd.ctl (All attempts (1) failed connecting to /var/run/clamav/clamd.ctl) at (eval 113) line 659.\n
Sep  2 11:38:47 xin amavis[2448]: (02448-01) (!)WARN: all primary virus scanners failed, considering backups
Sep  2 11:38:48 xin postfix/smtpd[2453]: connect from unknown[5.34.207.23]
Sep  2 11:38:48 xin postfix/smtpd[2455]: disconnect from unknown[5.34.207.23] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Sep  2 11:38:51 xin postfix/smtpd[2446]: warning: unknown[212.70.149.20]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Sep  2 11:38:51 xin postfix/smtpd[2650]: connect from unknown[5.34.207.23]
Sep  2 11:38:51 xin postfix/smtpd[2446]: disconnect from unknown[212.70.149.20] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Sep  2 11:38:54 xin postfix/smtpd[2455]: connect from unknown[212.70.149.68]
Sep  2 11:38:54 xin postfix/smtpd[2446]: connect from unknown[212.70.149.20]
Sep  2 11:38:54 xin postfix/smtpd[2873]: connect from unknown[5.34.207.23]
Sep  2 11:38:55 xin postfix/smtpd[2526]: warning: unknown[5.34.207.23]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Sep  2 11:38:56 xin postfix/smtpd[2526]: disconnect from unknown[5.34.207.23] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
 

ralphy

New Member
Wenn ich z.B. eine E-Mail von Extern (T-Online) an mich schicke kommt folgendes zurück:


This is the mail system at host mailout08.t-online.de.
I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.
For further assistance, please send mail to postmaster.
If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<ralxxx@olmix.de>: host mail.olmix.de[87.128.xxx.xxx] said: 554 5.7.1 Service
unavailable; Client host [194.25.134.20] blocked using zen.spamhaus.org;
Error: open resolver; https://www.spamhaus.org/returnc/pub/162.158.113.38
(in reply to RCPT TO command)

Reporting-MTA: dns; mailout08.t-online.de
X-Postfix-Queue-ID: A4AB9128A9
X-Postfix-Sender: rfc822; ralpxxxxx@t-online.de
Arrival-Date: Fri, 2 Sep 2022 11:42:25 +0200 (CEST)
Final-Recipient: rfc822; ralxxx@olmix.de
Original-Recipient: rfc822;ralxxx@olmix.de
Action: failed
Status: 5.7.1
Remote-MTA: dns; mail.olmix.de

Diagnostic-Code: smtp; 554 5.7.1 Service unavailable; Client host
[194.25.134.20] blocked using zen.spamhaus.org; Error: open resolver;
https://www.spamhaus.org/returnc/pub/162.158.113.38
 

Till

Administrator
Nimm mal unter System > Server config > Mail spamhaus bei den blacklisten raus. Und wegen ClamAV, wo hast Du den fehler bekommen, auf Deiner neuen VM? Möglicherweise hat die nicht genug RAM, 2GB sollten es schon sein für eine vollständige Installation.
 

Till

Administrator
Super, dass es wieder geht. Mit Spamhaus haben derzeit viele Leute Probleme, Spamhaus hat angefangen alle möglichen DNS Resolver zu sperren und dadurch fangen die mailsysteme dann einfach an Emails abzuweisen die kein Spam sind. Ist eine sehr üble Sache.
 

Werbung

Top