php7.4-fpm durch php8.1-fpm ersetzen. Was übersehe ich ?

fw114

Member
systemctl enable php8.1-fpm
Synchronizing state of php8.1-fpm.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable php8.1-fpm

php -v
PHP 8.1.12 (cli) (built: Oct 28 2022 18:35:51) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.1.12, Copyright (c) Zend Technologies
with Zend OPcache v8.1.12, Copyright (c), by Zend Technologies

update-alternatives --config php
Es gibt 3 Auswahlmöglichkeiten für die Alternative php (welche /usr/bin/php bereitstellen).

Auswahl Pfad Priorität Status
------------------------------------------------------------
0 /usr/bin/php8.1 81 automatischer Modus
1 /usr/bin/php7.4 74 manueller Modus
2 /usr/bin/php8.0 80 manueller Modus
* 3 /usr/bin/php8.1 81 manueller Modus

a2enconf php8.1*
Enabling conf php8.1-cgi.
Conf php8.1-fpm already enabled

Ich vermute mein Problem liegt hier:
a2enmod php8.1*
Considering dependency mpm_prefork for php8.1:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php8.1:
Module php8.1 already enabled


Deswegen wahrscheinlich bei php Prüfung von Joomla:
fpm-fcgi

PHP-Version 7.4.33

Wo habe ich vergessen die config anzupassen ?
Danke für Hinweise !
 
Zuletzt bearbeitet:

Werbung

Top