php.ini

#1
Hallo,
ich versuche jetzt für die 2. mal ernsthaft mit ISPConfig zu arbeiten.
Installation hat recht gut geklappt.

Nur . . .
PhpMyAdmin startet nicht (unknown URL)

php.ini - da scheint es schwer diese pro Webseite/Domain an zu passen open_basedir musste ich eigentlich ausschalten was mir nicht gelingt.

Gibt es Hints wie ich das hin kriege

Ubuntu 18.04 mit Mariadb und Apache - wie beschrieben auf Howtoforge

MfG
Jan
 

Till

Administrator
#3
Welche URL hast Du denn im Browser eingegeben für phpmyadmin?

php.ini - da scheint es schwer diese pro Webseite/Domain an zu passen open_basedir musste ich eigentlich ausschalten was mir nicht gelingt.
Anpassen der php.ini pro website ist sehr einfach, siehe php.ini Feld auf dem optionen reiter, da kannst Du einfach php.ini settings direkts etzen und warum bitte willst Du open_basedir abschalten? Macht Deinen Server nur unsicherer, wenn man noch auf andere Ordner zugreifen will die nicht zu der Website gehören dann fügt man die einfach hinzu. Aber abschalten geht natürlich genauso einfach, dazu trägt man den wert 'none' in das open_basedir Feld auf dem Optionen reiter der website ein, so wie es in der PHP Dokumentation auf steht.
 
#5
Dank eure Hilfe und Google läuft es jetzt

neu installiert
apt-get install libapache2-mod-php7.2

bei Systemkonfiguration - Sites
phpMyAdmin URL:
[SERVERNAME]/phpmyadmin (geht nicht)
/phpmyadmin (geht nicht)

Dann
nano /etc/apache2/apache2.conf
Then add the following line to the end of the file:
Include /etc/phpmyadmin/apache.conf
Then restart apache:
service apache2 restart

Dann startet phpMyAdmin
Nur https://devanswers.co/problem-php-7-2-phpmyadmin-warning-in-librariessql-count/
gepatched, Update kommt später.

open_basedir lasse ich mal wie es ist.
Das CMS meldet es soll ausgeschaltet aber es geht auch so, ohne Problemen.

php.ini Änderungen in php.ini-Feld auf dem Optionen-reiter da
habe ich nicht verstanden dass es etwas dauert vor Änderungen aktiv sind,
rote Punkt auf dem Bildschirm oben. Gefunden in Log-Dateien.

mfg
Jan
 

Till

Administrator
#6
Zu phpmyadmin: du hattest bei der installation nicht apache2 ausgewählt im apt installer Dialog von phpmyadmin wie im Tutorial beschrieben, sonst wäre das was Du jetzt gemacht nicht notwendig.
 

Werbung

Top