Let's encrypt schreibt alle Domains d. Servers in Zertifikat

RockinMC

New Member
Hallo zusammen,

aktuell bin ich für mich am Testen, wie ISPConfig funktioniert und stehe vor dem Problem, dass im SSL Zertifikat von domain1 sämtliche Domains (inkl. Subdomains) des kompletten Servers aller (unterschiedlicher) Kunden als "DNS Name" eingetragen hat.

Will heißen, dass ich als Kunde 1 die Domains von Kunde 2 sehe. Ist dies so gewünscht?

Herzlichen Dank für die Erhellung.
 

Till

Administrator
In ISPConfig hat jede Website ein eigenes Let's Encrypt SSL Zertifikat und dieses enthält nur die Domains der Website inkl der sub- und alias domains die dieser Webseite zugeordnet sind.

im Debug Mode kannst Du beim anlegen einer neuen website bzw. dem aktivieren von let's encrypt für eine website im Detail sehen, welche Domains zum zertifikat hinzugefügt werden. https://www.faqforge.com/linux/debugging-ispconfig-3-server-actions-in-case-of-a-failure/
 

RockinMC

New Member
Danke Till,
kann das also im Grunde nur daher rühren, dass ich das Erstellen d. SSL-Zertifikats via certbot direkt angestoßen habe oder?
Grund hierfür war, dass kein SSL Zertifikat erstellt wurde, als ich es mit ISPConfig versucht hatte. Der Hinweis mit dem Debug Mode werde ich testen. Merci vielmals.
 

Till

Administrator
Ja, niemals certbot manuell auf der shell nutzen auf ISPConfig systemen für domains die Du in ISPConfig verwaltest, das führt zu allen möglichen Problemen. ich hoffe Du hast certbot nicht erlaubt apache oder nginx config files zu ändern (also nicht im apache oder nginx Modus gestartet), denn dann sind alle deine configs jetzt so verändert dass die Websites nicht mehr über ISPConfig verwaltet werden können.

Grund hierfür war, dass kein SSL Zertifikat erstellt wurde, als ich es mit ISPConfig versucht hatte.
Siehe FAQ: https://www.howtoforge.com/community/threads/lets-encrypt-error-faq.74179/
 

Till

Administrator
Du musst im apache bzw. nginx sites-available und sites-enabled verzeichnis alle website vhosts löschen, deren dateien '-le' im namen haben.
 

RockinMC

New Member
Ok, das ist schonmal nicht der Fall. (keiner)
Nun müsste ich schlichtweg einfach nur abwarten, bis neue Zertifikate erstellt werden für (neue) Hosts, ob das dann klappt?
 

Till

Administrator
Ok, das ist schonmal nicht der Fall. (keiner)
Dann kann derzeit aber keine webiste SSL haben, wenn dochm, dann muss certbot noch was anderes geändert haben.

Nun müsste ich schlichtweg einfach nur abwarten, bis neue Zertifikate erstellt werden für (neue) Hosts, ob das dann klappt?
Du musst den Haken bei Let's encrypt in der website in ISPConfig aktivieren, dann speichern klicken, um SSL mit Let's encrypt für die website zu aktivieren. geht das nicht, dann geh Schritt für Schritt durch das FAQ.
 

RockinMC

New Member
Moin Florian,

danke für den Code (der bei mir ausgibt, dass /etc/nginx/sites-enabled ein Verzeichnis sei).
Es gibt in dem Verzeichnis keine Datei mit -le am Ende oder mitten drin. Gestern habe ich auch eine neue Subdomain erstellt, alte (mit SSL) bearbeitet und es hat geklappt.

Aktuell überlege ich allerdings, inwieweit ich nicht den Server sowieso neu aufsetze.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.