[ISPConfig3] DirectoryListing aktivieren

AndréS

New Member
Hallo Till,

ich würde gerne das DirectoryListing aktivieren. mod_autoindex ist ja schon aktiv, dennoch klappt das einfach nicht. Was muss ich machen damit das klappt?

Vielen Dank

AndréS
 

Till

Administrator
das ist an sich wie immer beim apache webserver, Options +Indexes innerhalb einer Directory Direktive.
 

AndréS

New Member
Das heißt ich muss diese Direktive direkt in die httpd.conf eingeben oder direkt im ISPConfig?

Danke

AndréS
 

AndréS

New Member
gut, ich habe nun sowas in die options von ispconfig rein getan:

Code:
<Directory "/var/www/clients/client1/web1"> 
        Options +Indexes 
        Order allow,deny 
        Allow from all 
</Directory>
funktioniert aber nicht :(
 

Till

Administrator
Dann füge mal zusätzlich noch den Symlink Pfad hinzu, also:

<Directory "/var/www/domain.de/web">
Options +Indexes
Order allow,deny
Allow from all
</Directory>
Außerdem fehlt bei Dir noch das Verzeichnis web im Pfad, also
/var/www/clients/client1/web1/web
 

AndréS

New Member
Hi,

danke, nun klappt es :) musste beide Sachen einsetzen, nur eins alleine geht definitiv nicht. Warum auch immer :)


AndréS
 

mpa

New Member
Hallo Till,

wollte nicht extra einen neuen Thread dafür aufmachen, deshalb schreibe ich hier mit dazu.

Wir haben die ISPConfig Version 3.0.4.3 bei uns im Einsatz und bereits die genannten Schritte durchgeführt. Es erscheint dennoch kein Verzeichnis-Listing. Im error.log steht "Directory index forbidden by Options directive:". Weder die Einträge für Options in der .htaccess noch den ispconfig files bei der Directory Direktive helfen hier weiter. Auch die globale Umstellung des Sicherheitslevels von high auf medium ändert nichts. Hast Du vlt. noch einen Tipp für uns?

Vielen Dank
Kai
 

Till

Administrator
Da gibt es an sich nur 3 Möglichkeiten:

1) Die Änderumngen wurden noch nicht in die Apache Config geschrieben. das kannst Du in der Jobqueue im Monitor sehen.

2) die Pfade stimmen in einem der beiden directory Statements nicht:

<Directory "/var/www/domain.de/web">
Options +Indexes
Order allow,deny
Allow from all
</Directory>
<Directory "/var/www/clients/client1/web1">
Options +Indexes
Order allow,deny
Allow from all
</Directory>

3) Oder aber die DirectoryIndex Freigabe wird durch eine .htaccess date in der webseite wieder aufgehoben.
 

mpa

New Member
Problem gelöst

Hallo Till,

danke für Deine schnelle Antwort.

Nachdem das Web im ISPConfig angelegt wurde, sollte das Directory-Listing für das root-Verzeichnis (web) aktiviert werden. Jedoch hat der Benutzer www-data, unter dem ja der Apache-Server läuft, keinen Lesezugriff auf das Verzeichnis. Nachdem manuell die Verzeichnisrechte auf "rwxr-x---" geändert wurden (also der Gruppe auch Leserechte gegeben), funktioniert das Directory-Listing.

Kai
 

Werbung

Top