ISPConfig 3.2 Zugriff auf ISPConfigPanel nach Neuinstallation von Apache nicht mehr möglich

pixeluser

Member
Hallo,

ich habe folgendes Problem, ich musste nach einem Upgrade von Debian 9 auf Debian 10 leider den apache2 server neuinstallieren, da es einige Abhängigkeitsprobleme mit PHP gab. Auf vorherigen Server liefen unterschiedliche PHP Versionen und mit dem Upgrade einiger Packte hat es den APACHE zerschossen.

Leider komme ich jetzt nicht mehr auf die ISPconfig Seite um die Seiten zu resyncen.

Folgendes habe ich bereits gemacht:

Code:
cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
tar xfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install/
php -q update.php
Hier habe ich reconfigure Serives yes gesagt

Bei
Code:
 wget -q -O htf-common-issues.php "http://gitplace.net/pixcept/ispconfig-tools/raw/stable/htf-common-issues.php" && php -q htf-common-issues.php
Bekomme ich folgende Meldung
Code:
##### SERVER #####
IP-address (as per hostname): ***.***.***.***
[WARN] could not determine server's ip address by ifconfig
[INFO] OS version is Debian GNU/Linux 10 (buster)
 
[INFO] ISPConfig is installed.

##### ISPCONFIG #####
ISPConfig version is 3.2


##### VERSION CHECK #####

[INFO] php (cli) version is 7.3.23-4+0~20201018.71+debian10~1.gbpfc8934

##### PORT CHECK #####

[WARN] Port 8080 (ISPConfig) seems NOT to be listening
[WARN] Port 22 (SSH server) seems NOT to be listening

##### MAIL SERVER CHECK #####


##### RUNNING SERVER PROCESSES #####

[INFO] I found the following web server(s):
    Apache 2 (PID 28985)
[INFO] I found the following mail server(s):
    Postfix (PID 28668)
[INFO] I found the following pop3 server(s):
    Dovecot (PID 28967)
[INFO] I found the following imap server(s):
    Unknown process (init) (PID 1)
[INFO] I found the following ftp server(s):
    PureFTP (PID 29013)

##### LISTENING PORTS #####
Server)        ()
Local        (Address)
[anywhere]:2812        (4573/monit)
[anywhere]:4190        (28967/dovecot)
[localhost]:20000        (1681/sogod)
[anywhere]:993        (1/init)
[anywhere]:995        (28967/dovecot)
[localhost]:11332        (636/rspamd:)
[localhost]:11333        (636/rspamd:)
[localhost]:11334        (636/rspamd:)
[localhost]:10023        (457/postgrey)
[localhost]:10024        (28886/amavisd-new)
[localhost]:10025        (28668/master)
[localhost]:10026        (28886/amavisd-new)
[localhost]:10027        (28668/master)
[anywhere]:587        (28668/master)
[localhost]:6379        (685/redis-server)
[localhost]:11211        (410/memcached)
[anywhere]:5355        (300/systemd-resolve)
[anywhere]:110        (28967/dovecot)
[anywhere]:31022        (464/sshd)
[anywhere]:143        (1/init)
[anywhere]:111        (1/init)
[anywhere]:465        (28668/master)
***.***.***.***:53        (29023/named)
[localhost]:53        (29023/named)
[anywhere]:21        (29013/pure-ftpd)
***.***.***.***:53        (300/systemd-resolve)
***.***.***.***:3478        (756/turnserver)
***.***.***.***:3478        (756/turnserver)
***.***.***.***:3478        (756/turnserver)
***.***.***.***:3478        (756/turnserver)
[localhost]:953        (29023/named)
[anywhere]:25        (28668/master)
*:*:*:*::*:443        (28985/apache2)
*:*:*:*::*:2812        (4573/monit)
*:*:*:*::*:4190        (28967/dovecot)
*:*:*:*::*:993        (1/init)
*:*:*:*::*:995        (28967/dovecot)
*:*:*:*::*:11332        (636/rspamd:)
*:*:*:*::*:11333        (636/rspamd:)
*:*:*:*::*:11334        (636/rspamd:)
*:*:*:*::*:10023        (457/postgrey)
*:*:*:*::*:10024        (28886/amavisd-new)
*:*:*:*::*:10026        (28886/amavisd-new)
*:*:*:*::*:3306        (28430/mysqld)
*:*:*:*::*:587        (28668/master)
*:*:*:*::*:6379        (685/redis-server)
*:*:*:*::*:5355        (300/systemd-resolve)
[localhost]10        (28967/dovecot)
*:*:*:*::*:##22        (464/sshd)
[localhost]43        (1/init)
[localhost]11        (1/init)
*:*:*:*::*:80        (28985/apache2)
*:*:*:*::*:8081        (28985/apache2)
*:*:*:*::*:465        (28668/master)
*:*:*:*::*:53        (29023/named)
*:*:*:*::*:21        (29013/pure-ftpd)
*:*:*:*::*:4949        (449/perl)
*:*:*:*::*:953        (29023/named)
*:*:*:*::*:25        (28668/master)
Was kann ich noch machen?
 

pixeluser

Member
Unter sites-enabled sieht das conf File für ispconfig das dann angelegt wird aus:

Code:
################################################
# ISPConfig General Apache Options
################################################
ServerTokens ProductOnly
ServerSignature Off

################################################
# ISPConfig Logfile configuration for vlogger
################################################

SetEnvIf Request_URI "^/datalogstatus.php$" dontlog

LogFormat "%v %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" /var/log/ispconfig/httpd" combined_ispconfig

<Directory /var/www/clients>
    AllowOverride None
        Require all denied
    </Directory>

# Do not allow access to the root file system of the server for security reasons
<Directory />
    Options -Indexes
    AllowOverride None
        Require all denied
    </Directory>

<Directory /var/www>
  Options -Indexes
</Directory>

<Directory /var/www/conf>
    AllowOverride None
        Require all denied
    </Directory>

# Except of the following directories that contain website scripts
<Directory /usr/share/phpmyadmin>
                Require all granted
        </Directory>

<Directory /usr/share/phpMyAdmin>
                Require all granted
        </Directory>

<Directory /srv/www/htdocs>
                Require all granted
        </Directory>

<Directory /usr/share/squirrelmail>
                Require all granted
        </Directory>

# Allow access to mailman on OpenSuSE
<Directory /usr/lib/mailman/cgi-bin>
                Require all granted
        </Directory>

<Directory /usr/lib/mailman/icons>
                Require all granted
        </Directory>

<Directory /var/lib/mailman/archives/>
        Options +FollowSymLinks
                Require all granted
        </Directory>

# allow path to awstats and alias for awstats icons
<Directory /usr/share/awstats>
                Require all granted
        </Directory>

Alias /awstats-icon "/usr/share/awstats/icon"


<IfModule mod_ssl.c>
  SSLStaplingCache shmcb:/var/run/ocsp(128000)
</IfModule>

<Directory /var/www/php-cgi-scripts>
  AllowOverride None
    Require all denied
  </Directory>

<Directory /var/www/php-fcgi-scripts>
  AllowOverride None
    Require all denied
  </Directory>
 
Zuletzt bearbeitet:

pixeluser

Member
Ein vhost File wird übrigens nicht angelegt. Wenn ich das manuell per Symlink mache bekomme ich zwar eine Seite aber die index.php wird nicht gefunden
 

pixeluser

Member
Ich hatte alle entsprechenden Pakete nachinstalliert. Mein Problem ist halt das ich die ispconfig.vhost Datei manuell per symlink in sites-enabled kopieren musste damit der apache2 überhaupt auf 8080 hört, allerdings wird dann nur die APACHE Default Seite angezeigt.
 

snocer

Member
Scheint das ich auch Probleme habe, abgelaufene Zertifikate LetsEncrypt, lassen sich nicht mehr erneuern. ISP Config 3.2 Version noch bestehende laufen noch. Hat da jemand einen Hinweis für mich, bin gerade etwas am verzweifeln, weil auch körperlich stark angeschlagen. Habe schon einigen Stress deswegen.
 

Till

Administrator
Mit der Erneuerung von LE Zertifikaten hat ispconfig nichts direkt zu tun, ispconfig ruft auch nur certbot --renew auf einmal am Tag. Schau ins letsencrypt.log, warum certbot die Zertifikate nicht erneuern kann. Häufige Ursache ist eine zu alte certbot version.
 

snocer

Member
Danke für Dine Antwort. Wir kann ich das prüfen und gegebenenfalls beheben?
ein certbot --renew scheint ja nicht zu reichen. Sorry wen ich so dumm Frage.
certbot renew --dry-run
 
Zuletzt bearbeitet:

Till

Administrator
Danke für Dine Antwort. Wir kann ich das prüfen und gegebenenfalls beheben?
ein certbot --renew scheint ja nicht zu reichen. Sorry wen ich so dumm Frage.
Das hatte ich Dir doch oben bereits geschrieben:

"Schau ins letsencrypt.log, warum certbot die Zertifikate nicht erneuern kann."

Und ansonsten für jegliche Probleme mit Let's Encrypt:

 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.