[Gelöst] Umstellung auf reines IPV6 Multiserver setup

etron770

Member
Wenn ich beim Master oder Slave die IPV4 herausnehme kommt beim .../server.sh ein Datenbankfehler

aber auch der Zugriff mysql -u myuser -p -h server.de funktioniert nur wenn auf beiden VMs ipv4 vorhanden ist.
ERROR 2002 (HY000): Can't connect to MySQL server on 'server.de ' (101)


die ISPUser sind auf dem Master mit domain.xy IPV6 und IPV4 eingetragen

Was muss ich da noch anpassen ...
 

Till

Administrator
Hast Du in den /etc/hosts Dateien aller slaves und des masters den master und die anderen slaves auch als IPv6 Adressen eingetragen?
 

etron770

Member
mal ganz ohne Ispconfig:
Server mit reinem IPV6 kann ich mit ping sub.server.de mit ipv6 anpingen
Server mit IPV4 kann ich sich auf die Datenbank Master mit root und -u -p -h master.server.de anmelden
nehme ich auf dem Masterserver die IP4 heraus kommt
ERROR 2002 (HY000): Can't connect to MySQL server on 'master.server.de' (115)

ping zu ipv6 sub1.server.de vom master.server.de und zurück klappt

Auf dem master ist root sub.server.de mit ALL PRIVILEGES angelegt
Auf dem master ist root mit IPV6 des sub.server.de mit ALL PRIVILEGES angelegt
 

Till

Administrator
Genau, ich meinte den -h parameter, da kannst Du ja einen Hostnamen oder eine Ip angeben und ich würde mal sagen dass eine ipv6 so auch angegeben werden kann um die verbindung darüber zu erzwingen und somit zu testen. Denn wenn das nicht geht, braucht man es von extern garnicht erst versuchen bzw. man schließt so Probleme die durch Firewalls vorhanden sien könnten aus. Ich nutze meine mysql server nicht via IPv6, daher kann ich da nichts im detail zu sagen, schau am besten mal in der mysql bzw. mariadb doku oder google danach.
 

etron770

Member
Jaaa ... nano /etc/mysql/mariadb.conf.d/50-server.cnf auf dem Master
da war bind-address = 0.0.0.0

Aber warum bin ich dann mit IPV4 auf den Server gekommen?
Funktioniert ... grep ist einfach was Feines :)
 

etron770

Member
Achso - ja, da war ich schon danke - das hatte nicht funktioniert, weil ich es im falschen .cf eingegeben hatte
Irgendwann weiß man nicht mehr was man schon alles probiert hatte :oops:
 

etron770

Member
gelöst o_O nachdem die IPV4/IPV6 VM (Webserver) partout die IPV4 Adresse des Masters nicht vergessen wollte und ich dort noch IPV4 drauf lassen möchte, hab ich mal in der /etc/hosts nachgeschaut.
Da habe ich irgendwann mal die IP des Masters eingetragen, weil TTL auf 24 Stunden stand und ich nach dem IP Wechsel gleich testen wollte.
Und wenn da die IP drin steht fragt die VM nicht mehr die DNS Server ab ...
 

Werbung

Top