[GELÖST] ISPC 3.1.15p3: Nach Upgrade auf Ubuntu 20.04 Probleme mit PHP 7.4

Mettwurscht

New Member
Hallo zusammen,

ich hatte ein ISPconfig 3.1.15p3 (nginx) auf einem Ubuntu 18.04. Auf dem System habe ich vor Erscheinen der Ubuntu 20.04.1 ein Upgrade auf 20.04 erzwungen, das soweit auch gut durchlief. Auch das ISPconfig hatte keine wirklichen Probleme damit. Einzig in der /etc/nginx/sites-available/ispconfig.vhost musste ich die Teile mit php7.4 wieder auf php7.2 zurückbiegen.

Nun ist zwischenzeitlich Ubuntu 20.04.1 erschienen sowie die 3.2 Beta von ISPconfig. Soweit klappt auch alles. Allerdings ist so, dass das install/update-Skript von ISPconfig in die ispconfig.vhost eine Variable auf php7.4 setzt:

NGINX:
fastcgi_pass unix:/var/lib/php7.4-fpm/ispconfig.sock;
Damit läuft das Webinterface von ISPconfig aber nicht. Im log steht die Meldung:

NGINX:
2020/10/13 15:43:52 [crit] 924#924: *4 connect() to unix:/var/lib/php7.4-fpm/ispconfig.sock failed (13: Permission denied) while connecting to upstream, client: 95.208.x.x, server: _, request: "GET /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php7.4-fpm/ispconfig.sock:", host: "ispconfig.example.net:8080",
referrer: "https://ispconfig.example.net:8080/login/"
Sobald ich in der vhost-Datei php7.4 durch php7.2 ersetze, funktioniert das Webinterface.

Die übrigen Websites laufen. In der Serverconfig wurde unter den PHP Einstellungen php7.2 durch php7.4 ersetzt.

Hat mir jemand eine Idee, wie ich das reparieren kann?
 

Mettwurscht

New Member
Hier noch etwas Nachschlag:

Es gibt zwei config-Dateien

/etc/php/7.2/fpm/pool.d/ispconfig.conf
/etc/php/7.4/fpm/pool.d/ispconfig.conf

Beide Dateien sind quasi komplett identisch - mit Ausnahme der Pfade:

listen = /var/lib/php7.2-fpm/ispconfig.sock
listen = /var/lib/php7.4-fpm/ispconfig.sock

Beide Dateien existieren und haben die selben Rechte.
 

Till

Administrator
Da sind bei Dir scheinbar noch Reste der Ubuntu 18.04 config vorhanden.

Lösch mal die alte Datei /etc/php/7.2/fpm/pool.d/ispconfig.conf
Dann mach Deine Änderung am ispconfig.vhost rückgängig.

Dann starte php7.2-fpm neu und dann php7.4-fpm.
 

Mettwurscht

New Member
Hat leider nichts gebracht.

Im Browser bekomme ich 502 Bad Gateway und im nginx-log steht die selbe Meldung wie im OP.

Außerdem muss ich noch etwas berichtigen:
Wenn ich in der Serverkonfig unter PHP alles auf PHP7.4 umstelle, in einer Website PHP deaktiviere und nochmals aktivere, erhalte ich dort ebenfalls den Fehler 502.

Wenn ich aber eine zusätzliche PHP-Version 7.4 einrichte, und diese in einer Website einstelle, läuft die Website mit PHP 7.4 (dazu ist in der Serverkonfiguration wieder PHP 7.2 eingestellt).

In der Serverkonfiguration muss jedoch weiterhin PHP 7.2 eingestellt bleiben.

Irgendetwas muss es ja ganz gehörig durcheinander gebracht haben.

Ich hatte auch mal PHP komplett von der Kiste gelöscht und nur PHP 7.4 wieder installiert. Ohne Erfolg. Wieder nur Error 502.
 

Till

Administrator
Schau mal in das globale error.log und die error.logs der betroffenen webseiten um zus ehen was mit dem php 7.4 nicht stimmt. Nach einem Upgrade auf 20.04 musst Du alle sachen in der glovbalen config auf php 7.4 umstellen.
 

Mettwurscht

New Member
Folgende Schritte habe ich eben zur Reproduktion des Fehlers durchgeführt:

1. Serverkonfiguration: PHP 7.2 auf PHP 7.4 umgestellt:
ISPC_serverconfig_PHP.png

2. An allen Websites PHP deaktiviert

3. Zusätzliche PHP-Version 7.4 deaktiviert

4. /usr/local/ispconfig/server/server.sh

5. PHP in einer Website aktiviert und auf Default gestellt

6. /usr/local/ispconfig/server/server.sh
Bash:
root@host:/var/log/nginx# /usr/local/ispconfig/server/server.sh
14.10.2020-10:04 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
14.10.2020-10:04 - DEBUG - Found 1 changes, starting update process.
14.10.2020-10:04 - DEBUG - Calling function 'ssl' from plugin 'nginx_plugin' raised by event 'web_domain_update'.
14.10.2020-10:04 - DEBUG - Calling function 'update' from plugin 'nginx_plugin' raised by event 'web_domain_update'.
14.10.2020-10:04 - DEBUG - safe_exec cmd: chattr -i '/var/www/clients/client2/web29' - return code: 0
14.10.2020-10:04 - DEBUG - safe_exec cmd: chattr +i '/var/www/clients/client2/web29' - return code: 0
14.10.2020-10:04 - DEBUG - safe_exec cmd: df -T '/var/www/clients/client2/web29'|awk 'END{print $2,$NF}' - return code: 0
14.10.2020-10:04 - DEBUG - safe_exec cmd: which 'setquota' 2> /dev/null - return code: 0
14.10.2020-10:04 - DEBUG - safe_exec cmd: setquota -u 'web29' '15360' '16384' 0 0 -a &> /dev/null - return code: 0
14.10.2020-10:04 - DEBUG - safe_exec cmd: setquota -T -u 'web29' 604800 604800 -a &> /dev/null - return code: 0
14.10.2020-10:04 - DEBUG - safe_exec cmd: chattr -i '/var/www/clients/client2/web29' - return code: 0
14.10.2020-10:04 - DEBUG - safe_exec cmd: usermod --groups sshusers 'web29' 2>/dev/null - return code: 0
14.10.2020-10:04 - DEBUG - safe_exec cmd: chattr +i '/var/www/clients/client2/web29' - return code: 0
14.10.2020-10:04 - DEBUG - Enable SSL for: sub.example.net
14.10.2020-10:04 - DEBUG - Writing the vhost file: /etc/nginx/sites-available/sub.example.net.vhost
14.10.2020-10:04 - DEBUG - Writing the PHP-FPM config file: /etc/php/7.4/fpm/pool.d/web29.conf
14.10.2020-10:04 - DEBUG - Calling function 'restartPHP_FPM' from module 'web_module'.
14.10.2020-10:04 - DEBUG - Restarting php-fpm: systemctl reload php7.4-fpm.service
14.10.2020-10:04 - DEBUG - nginx status is: running
14.10.2020-10:04 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
14.10.2020-10:04 - DEBUG - Checking nginx configuration...
14.10.2020-10:04 - DEBUG - nginx configuration ok!
14.10.2020-10:04 - DEBUG - Restarting httpd: systemctl restart nginx.service
14.10.2020-10:04 - DEBUG - nginx restart return value is: 0
14.10.2020-10:04 - DEBUG - nginx online status after restart is: running
14.10.2020-10:04 - DEBUG - Processed datalog_id 3636
14.10.2020-10:04 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished server.php.
Aufruf der Website führt nun zu Fehler 502 Bad Gateway

/var/log/nginx/error.log:
Kein Eintrag.

error.log der Website:
NGINX:
2020/10/14 10:05:55 [crit] 76161#76161: *30 connect() to unix:/var/lib/php7.4-fpm/web29.sock failed (13: Permission denied) while connecting to upstream, client: 93.235.x.x, server: sub.example.net, request: "GET /admin/ HTTP/2.0", upstream: "fastcgi://unix:/var/lib/php7.4-fpm/web29.sock:", host: "sub.example.net"
 

Mettwurscht

New Member
Ich habe nun alles wieder zurückgerollt. Also in der Serverconfiguration wieder PHP 7.2 eingestellt und die zusätzliche PHP-Version 7.4 aktiviert.

Dann habe ich an der Website wieder PHP 7.4 eingerichtet und jetzt kommt was merkwürdiges:

Das ISPconfig-Log sagt zwar:

Writing the PHP-FPM config file: /etc/php/7.4/fpm/pool.d/web29.conf

Aber in dieser Datei steht dann:

listen = /var/lib/php7.2-fpm/web29.sock

Wobei phpinfo ganz klar PHP 7.4 sagt.

Nachtrag: Das scheint normal zu sein. Auf einem anderen Server, auf dem 7.0 default ist, werden die socks auch unter /var/lib/php7.0-fpm angelegt, wenn PHP 7.1, 7.2 oder 7.4 eingestellt wird.
 
Zuletzt bearbeitet:

Mettwurscht

New Member
Und noch ein Nachtrag:

Ich hab mal die Rechte unter /var/lib gecheckt:
drwxr-xr-x 2 root root 4096 Okt 14 10:27 php7.2-fpm
drwx------ 2 root root 4096 Okt 14 10:26 php7.4-fpm


Ich teste mal was und melde mich gleich wieder...

OMFG! Ich hab die ganze Zeit die Rechte der socks geprüft anstatt mal die Rechte des Verzeichnisses zu prüfen. Ich gehe nun wieder ins Bett und weine. Das Problem scheint gelöst zu sein.

Sorry, Till, dass ich deine Zeit verschwendet habe.
 
Zuletzt bearbeitet:

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.