[Gelöst] Chroot FPM

logifech

Member
Hallo,
folgendes Verhalten habe ich beobachtet, Perfect Server Tutorial dient hier als Basis für den Server mittels Debian 10 und Apache2, zusätzlich dazu Mehre PHP Versionen 5.6-8.0 über das Repo von Jury installiert.

Wenn ich eine Website anlege mit php ohne FPM Chroot kann ich über "/phpmyadmon" alles normal erreichen, lege ich nun php-fpm als chroot an, zeigt er mir an "File not found."

Wenn ich nun wieder FPM-Chroot deaktiviere löscht er die ganzen Chroot Verzeichnisse im Webroot nicht (lib;etc;dev etc.) ist dies so gewollt, wenn ja warum?

Gruß
logifech
 

Till

Administrator
Wenn ich eine Website anlege mit php ohne FPM Chroot kann ich über "/phpmyadmon" alles normal erreichen, lege ich nun php-fpm als chroot an, zeigt er mir an "File not found."
Das ist richtig, phpmyadmin über die website domain kann dann auch nnicht funktionieren, da es ja chrooted ist und phpmyadmin nicht im chroot liegt. auf phpmyadmin sollte man immer über den server hostnamen zugreifen.

Wenn ich nun wieder FPM-Chroot deaktiviere löscht er die ganzen Chroot Verzeichnisse im Webroot nicht (lib;etc;dev etc.) ist dies so gewollt, wenn ja warum?
Das ist so gewollt da das chroot auch für andere Bereiche genutzt wird und insbesondere da ISPConfig nicht feststellen kann ob irgendeine der dateien noch benötigt wird oder ob irgendwo eigene dateien angelegt wurden.

Um es zusammen zu fassen, das was Du beschrieben hast muss so sein, es liegt hier kein bug vor.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.