Fehler bei Update von ISPConfig 3.1 auf 3.2

BaRt

New Member
Hallo Community :)

ich habe eben gesehen das dass Update 3.2 verfügbar ist und wollte direkt ein Update machen.
Leider kommt bei mir ein Fehler beim starten des Updates.
Eventuell liegt es daran das ich gerade mehrere PHP Versionen nach installiert habe und in ISPConfig eingetragen.
Aber im Grunde dürfte es daran ja nicht liegen.
Ich hab in der Server-Konfiguration auch testweise die genutzte PHP Version auf 7.4 gestellt. Aber das hat nichts genützt.

hier die Konsolenausgabe:

--------------------------------------------------------------------------------
_____ ___________ _____ __ _ ____
|_ _/ ___| ___ \ / __ \ / _(_) /__ \
| | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ _/ /
| | `--. \ __/ | | / _ \| '_ \| _| |/ _` | |_ |
_| |_/\__/ / | | \__/\ (_) | | | | | | | (_| | ___\ \
\___/\____/\_| \____/\___/|_| |_|_| |_|\__, | \____/
__/ |
|___/
--------------------------------------------------------------------------------


>> Update

Operating System: Ubuntu 18.04.5 LTS (Bionic Beaver)

PHP Deprecated: Function get_magic_quotes_runtime() is deprecated in /usr/local/ispconfig/server/lib/config.inc.php on line 48
PHP Curl Module is missing.
PHP MySQLi Module is nmissing.
PHP Multibyte Module (MB) is missing.

Die Fehler
( PHP Curl Module is missing.
PHP MySQLi Module is nmissing.
PHP Multibyte Module (MB) is missing. )
konnte ich durch Installation der fehlenden Module beheben.

jedoch bleibt der Fehler das in der config.inc.php in Zeile 48 eine veraltete Funktion ist.

Wo liegt der Fehler und wie behebe ich das ganze ?
Oder ist der Fehler behoben und die Warnung kann ich ignorieren ?
Ich versuche das Update mal durchlaufen zu lassen


nette Grüsse :))
 

BaRt

New Member
So habe das Update durchlaufen lassen. Hat nach dem nachinstallieren der Module dann geklappt.
Fehler nur wie gesagt die Warnung von get magic..
Und beim Update kam die Meldung das Xmpp nicht erkannt wurde.
Hier mal die Konsolenausgabe :

root@server:/tmp/ispconfig3_install/install# php -q update.php


--------------------------------------------------------------------------------
_____ ___________ _____ __ _ ____
|_ _/ ___| ___ \ / __ \ / _(_) /__ \
| | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ _/ /
| | `--. \ __/ | | / _ \| '_ \| _| |/ _` | |_ |
_| |_/\__/ / | | \__/\ (_) | | | | | | | (_| | ___\ \
\___/\____/\_| \____/\___/|_| |_|_| |_|\__, | \____/
__/ |
|___/
--------------------------------------------------------------------------------


>> Update

Operating System: Ubuntu 18.04.5 LTS (Bionic Beaver)

PHP Deprecated: Function get_magic_quotes_runtime() is deprecated in /usr/local/ispconfig/server/lib/config.inc.php on line 48
This application will update ISPConfig 3 on your server.

Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:

Creating backup of "/usr/local/ispconfig" directory...
Creating backup of "/etc" directory...
mysqldump: [Warning] Using a password on the command line interface can be insecure.
Checking ISPConfig database .. mysqlcheck: [Warning] Using a password on the command line interface can be insecure.
OK
mysql: [Warning] Using a password on the command line interface can be insecure.
Starting incremental database update.
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0089.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_0090.sql
Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_dev_collection.sql
Reconfigure Permissions in master database? (yes,no) [no]:

Service 'xmpp_server' has not been detected (strongly recommended, currently enabled) do you want to disable it? (yes,no) [yes]: no

Reconfigure Services? (yes,no,selected) [yes]:

Configuring Postfix
Configuring Dovecot
Configuring Spamassassin
Configuring Amavisd
Configuring Getmail
Configuring BIND
Configuring Pureftpd
Configuring Apache
Configuring vlogger
Configuring Apps vhost
Configuring Jailkit
Configuring Ubuntu Firewall
Configuring Database
Updating ISPConfig
ISPConfig Port [8080]:

Create new ISPConfig SSL certificate (yes,no) [no]:

Reconfigure Crontab? (yes,no) [yes]:

Updating Crontab
Restarting services ...
Update finished.
root@server:/tmp/ispconfig3_install/install#


System: Ubuntu 18.04 LTS Desktop - minimal installation


nette Grüsse :)
 

Till

Administrator
Dein altes ispconfig kann auch nicht mehr funktioniert haben, hast Du vermutlich nur noch nicht bemerkt da es nur den server teil betraf, denn die fehlenden PHP module benötigt auch ISPConfig 3.1. Vermutlich hast Du aus versehen die basis PHP Version Deines Ubuntu system getauscht und dann nicht alle notwendigen Module installiert, was dann zu solchen fehlern führt. Das macht auch gern das ondrej Ubuntu repositiry beim einfachen apt-get upgrade ohne weitere nachfrage, ist ein bekannter Fehler beim Ondrej Repository dass es ungefragt PHP Versionen tauscht, hat also nichts mit dem ISPConfig Update oder der 3.2 Version zu tun.

Service 'xmpp_server' has not been detected (strongly recommended, currently enabled) do you want to disable it? (yes,no) [yes]: no
Das ist ok.
 

BaRt

New Member
danke Till, mal wieder für deine schnelle Antwort :)
ja wie gesagt kann sein das ISP nicht richtig funktioniert hat, habe aber keinen Absturt gemeldet bekommen.
Aber waren auch nur minutenb nachdem ich die PHP Versionen dazugepackt habr nach einer ISPConfig anleitung.

Ja ist mein Problem nun behoben durch das nachinstallieren der Funktionen oder ist da noch der Wurm drin und falls ja wie bekommne ich den wieder raus ohne das System neu aufzusetzen. ?

Gebe dir auch gern kurz Zugang zum Server wenn du magst.

Wie gesagt bin mit ISP Config noch etwas überfragt. Aber arbeite mich ja gerade ein :))

nette Grüsse
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.