Falsches Routing

#1
Hi Zusammen,

ich hab debian/jessie mit aktuellem ispconfig

Aktuell laufen 10 subdomains darüber. Jede Subdomain ist mit https von letsencrypt versorgt.

Jede Subdomain hat einen Apache Direktive wie diese:


Code:
ProxyPreserveHost On
ProxyRequests On
ProxyVia On
ProxyPass / http://IP:9701/
ProxyPassReverse / http://IP:9701/
Die zeigt immer auf irgendeinen Docker container. Das Funktioniert wunderbar.


So jetzt hab ich eine subdomain bei der ich was ändern musste und diese funktioniert jetzt nicht mehr. Eigentlich nur den Port geändert.
Ich hab die dann gelöscht und neu angelegt.

Jetzt ist es so dass immer wenn ich

https://subdomainA.domain.de aufrufe wird auf https://subdomainB.domain.de redirected.

SubdomainA ist die die ich gelöscht hatte und neu angelegt ...

Woran könnte das liegen?
Danke im Voraus
 

Till

Administrator
#2
Vermutlich kein SSL mehr aktiv, in dem Fall muss der web server auf das nächste web in alphabetischer reihenfolge umleiten. Prüf das mal und schau ggf. in den vhost. Sowas kann passieren wenn Du bei Deiber proxy Weiterleitung nicht den well known Ordner von LE ausgeklammert hast, denn dann kann sich LE weder verlängern noch kann LE erneut erzeugt werden und somit kein LE mehr in dem web aktiv sein.
 

Till

Administrator
#4
Eine Datei sub.domain.vhost-le-ssl.conf darf es auf ISPConfig systemen nicht geben denn bei ISPConfig sind SSL und non SSL Vhost immer in der selben datei. Wenn es Dateien mit *-le-ssl.conf auf dem System gibt, dann wurde der Fehler begangen certbot mit --apache Option auf der Shell zu verwenden anstatt Let's encrypt in ISPConfig zu aktivieren, das Resultat sind nicht funktionierende websites bzw. websites bei denen man SSL nicht mehr aktivieren kann bazw. keine Änderungen über ISPConfig durchführen kann und bei Seiten mit PHP fällt Apache sogar komplett aus da Certbot einen Fehler hat und Einträge die es nur einmal pro Server geben darf dupliziert.
 

Till

Administrator
#5
Certbot validiert Domaisn indem es einen Token aus einem 'virtuellen' verzeichnis .well-known/acme-challenge/ des webs abruft, wenn Du jetzt per Proxy weiter leitest und URL's die mit .well-known/acme-challenge/ beginnen nicht von der Weiterleitung an Docker ausgeschlossen hast, dann kann Let's encrypt keine SSL zertifikate für die Domain mehr ausstellen und somit wird dann SSL für die Webseite durch ISPConfig deaktiviert, da es kein SSL cert gibt.
 
#6
Okay und wie bekomme ich das wieder in den Griff?

Hab die Subdomain die nicht funzt gelöscht

Jetzt Leg ich die neu an und setze wie vorher auch in ispconfig le?

Und dann ich muss immer certbot ausführen alleine macht er das nicht ...

Was muss ich noch machen daß es wieder funzt?
 
#8
Okay ich hab das jetzt so geändert jetzt routet es wieder richtig. ist aber super langsam. Wenn ich die Applikation über ip+port aufrufe ist sie zack da.

über die URL dauert es aber bis zu 2min
 
#9
Hmmm es sollte ein Denkanstoß sein, damit laufen meine Sachen mit LE einwandfrei.
z.B. ein otrs... hier musst Du mal schauen, was genau Du eingetragen hast. DNS-Lookup etc.... sind aber alles nur Vermutungen aus der Glaskugel.
 

Till

Administrator
#10
Wenn es mit IP schnell ist und mit Domain Name langsam, dann hat es vermutlich was mit der Namensauflösung zu tun bzw. irgend was muss erst in einen Timeout laufen bevor das Ergebnis erscheint.
 

Werbung

Top