DNS Tool nach Kundenerstellung aktiv obwohl deaktiviert

Germanius

Member
Obwohl ich hier /usr/local/ispconfig/interface/lib/config.inc.php und hier /usr/local/ispconfig/server/lib/config.inc.php folgende Zeile habe..

PHP:
$conf['interface_modules_enabled'] = 'dashboard,mail,sites,tools';
..aktiviert er das DNS Tool nach einer Kundenerstellung trotzdem immer. Ich muss es dann über den Systembenutzer deaktivieren.
Muss man das noch irgendwo deaktivieren, damit es automatisch deaktiviert ist?
 

Till

Administrator
Ist das ein aktuelles ISPConfig 3.0.3.2? Ich hab gerade mal im Code nachgesehen und dort wird die Modulliste beim erstellen eines neuen Kunden definitiv aus der Variable $conf['interface_modules_enabled'] genommen.

Ein andere Sache könnte sein, dass Du Dich nach dem Ändern von $conf['interface_modules_enabled'] nicht neu eingeloggt hast, den alles was in $conf steht wird in der Session gecached.
 

Germanius

Member
Das ist noch die 3.0.3 Version.
Geändert habe ich es irgendwann vor ein paar Monaten, ist mir jetzt nur aufgefallen, am Cachen sollte es also nicht liegen.

Ich werde später mal auf die 3.0.3.2 updaten und schauen, ob es dann immer noch ist.
 

Germanius

Member
Nach dem Update auf 3.0.3.2 bestand das Problem immer noch. Ich lege die Clients standardmäßig über die API an. Hab nun mal einen übers Panel angelegt und siehe da, dort funktioniert es. Nur über die API nicht.
Kann man das gesondert einstellen?
 
Zuletzt bearbeitet:

Till

Administrator
Es kann sein dass die Modulliste im remoting API hart reinkodiert ist. Müsstest Du ggf. mal in den beideb remoting klassen dateien nachsehen.
 

Germanius

Member
Danke, ist tatsächlich so wie du sagst.

Steht hart in der /usr/local/ispconfig/interface/lib/classes/remoting_lib.inc.php drin und nachdem ich dort dns entfernt habe geht es auch.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.