Die Installscripts

Esolein

Member
Hallo,
also die Installscripts würde ich rausnehmen und ggf. nochmal bearbeiten.

Die sind sehr sehr fehlerhaft.

bsp:
flex, bison, debhelper, binutils
[INFO] Installed packages quota, quotatool, haveged, geoip-database, libclass-dbi-mysql-perl, libtimedate-perl, build-essential, autoconf, automake, libtool, flex, bison, debhelper, binutils
[INFO] Installing packages pure-ftpd-common, pure-ftpd-mysql, webalizer, awstats
[ERROR] Exception occured: ISPConfigOSException -> Installing packages failed. (/ispconfig.ai.php:15)
root@h2923833:/tmp/ispconfig-au

entweder hängt es am pureftpd oder am Quota und man kann NICHTS machen.

Trotz dem wert --no-quota

Ebenso sind einige verlinkungen seitens wget nicht mehr AKTUELL.
Jemand eine neuere Version ???

Danke
Edit:
Ubuntu teste ich nun auch und werde ebenso ein Feedback geben.
 

Esolein

Member
Auch die ubuntu installation weist fehler auf:


sh: 1: add-apt-repository: not found
[ERROR] Exception occured: ISPConfigOSException -> Command add-apt-repository -y ppa:eek:ndrej/php failed. (/ispconfig.ai.php:15)


Also wenn nun ein großes Unternehmen dahinter stecken würde, wäre das verlorene Zeit.
 

Till

Administrator
Gerade gestern einen Server mit dem Autoinstaller installiert, Debian 10 Nginx web server, lief ohne Probleme und Installation läuft perfekt. Basis System war ein ganz normaler Hetzner cloud server cx11 mit Debian 10.

Spaßeshalber habe ich jetzt gerade nochmal einen Server mit allen Diensten und apache installiert, exakt wie beim ai beschrieben:

Code:
curl https://get.ispconfig.org | sh
Läuft auch perfekt. Hier mal der gesamte install (als angehängte Textdatei).

Da Du es weder schaffst manuell noch mit autoinstaller einen Server zu installieren spricht also eher dafür dass Du da ein komplett verbasteltes oder untaugliches Basissystem verwendest als für Probleme die am Autoinstaller oder an ISPConfig liegen, denn wenn schon simple apt Befehle oder ein add-apt-repository Befehl nicht geht, dann hat das mit ISPConfig oder dem Autoinstaller nichts zu tun sondern mit Deinem Basis System.

Du solltest Dir ernsthaft überlegen ob es nicht besser ist wenn Du Dir irgendwo einen Webspace mietest oder meinetwegen auch einen managed server als zu versuchen selbst einen Server zu hosten.
 

Anhänge

Till

Administrator
Und da Du jetzt sicherlich behaupten wirst dass es natürlich nur unter Debian 10 geht und auch die --no-quota Option nicht geht, habe ich nochmal schnell eine Installation Auf einem hetzner cx11 cloud server mit Ubuntu 20.04 gemacht, läuft auch perfekt. Install Log wieder im Anhang.

Installations Befehl:

Code:
curl https://get.ispconfig.org | sh -s -- --no-quota
Daher kann ich Dir wirklich nur raten erstmal mehr über Linux zu lernen, z.B. wie man mit apt Pakete installiert, wie man auf der Shell arbeitet und Verzeichnisse erstellt oder Text-Dateien mit nano editiert etc. Und wenn Du dann die Basics kannst, dann versuch Dich mal einem simplen LAMP system. Und solange hostest Du am besten nicht selbst sondern mietest eine Webseite, denn selbst hosten heißt auch Verantwortung dafür zu übernehmen wenn eine Webseite oder der Server vielleicht mal gehacked wird und Dein Server andere Systeme angreift weil Du nicht verstehst was da passiert.

Und wenn Du trotz allem meinst selbst hosten zu wollen, dann musst Du zumindest ein korrekt installiertes Basis System nehmen. So ein cloud server wie das System das ich zum testen genommen habe kostet heutzutage nichtmal mehr 3 eur im Monat, das sollte man schon über haben wenn man selbst hosten will.
 

Anhänge

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.