Der perfekte Server – Debian 10.....failed

st0ne

New Member
Der Apache startet nicht mehr
AH00526: Syntax error on line 75 of /etc/apache2/sites-enabled/000-apps.vhost:
Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the server configuration
Action 'start' failed.
und das ganz am ende nachdem ipspconfig installiert wurde
was kann man da machen ?
 
Zuletzt bearbeitet:

matz

Member
Mal so ganz naiv gefragt: Ist das Modul mod_suexec aktiviert? a2enmod mod_suexec müsste die Befehlszeile lauten, danach den Indianer neu starten. Ich bin ein Nginx-Mensch aber Apache ist auf der lokalen Maschine in Betrieb.
 

Till

Administrator
Ja, da ist definitiv suexec nicht aktiviert, es steht aber im Tutorial drin der Befehl zum aktivieren. Er lautet:

a2enmod suexec

und danach apache neu starten.
 

st0ne

New Member
Zum einen stimmte es das suexec war deaktiviert.

":~# a2enmod suexec
Module suexec already enabled"

daran lag es nicht nur allein.
Jetzt tritt ein anderes Problem auf

"Syntax error on line 64 of /etc/apache2/sites-enabled/000-ispconfig.vhost:"
"Invalid command 'SSLProtocol', perhaps misspelled or defined by a module not included in the server configuration"

62. # SSL Configuration
63. SSLEngine On
64. SSLProtocol All -SSLv3 -TLSv1 -TLSv1.1
 

Till

Administrator
Geh bitte nochmal durch das ganze Kapitel der apache und php installation aus dem perfect server tutorial und führ jeden Befehl nochmal aus.
 

st0ne

New Member
Geh bitte nochmal durch das ganze Kapitel der apache und php installation aus dem perfect server tutorial und führ jeden Befehl nochmal aus.
gesagt getan....Erfolgreich abgeschlossen.
Fehler war wohl :
Nach der installation
:~# apt-get -y install apache2 apache2-doc.........
stand dort
To activate the new configuration, you need to run:
systemctl restart apache2
und das habe ich schon bevor es im Tutorial stand ausgeführt, den es sollte anschließend dies noch ausgeführt werden.
root@:~# nano /etc/apache2/conf-available/httpoxy.conf
root@:~# a2enconf httpoxy
Conf httpoxy already enabled
root@:~# systemctl restart apache2
root@:~#
nun funktioniert alles .
Danke für Eure / Deine Unterstützung
 
Zuletzt bearbeitet:

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.