[Debian 11] Verständnisfrage Nginx

Edward

New Member
Hi. Ich habe zum Test eine WordPress Seite eingerichtet die auf der Domain "dev2.domain.com" läuft, diese ist mit HTTP und HTTPS erreichbar.

Außerdem habe ich die Subdomains dev3.domain.com, dev4.domain.com, dev5.domain.com usw. jeweils als eigene Website eingerichtet und deaktiviert (sind für die Zukunft). Wenn ich die Subdomains nur mit HTTP aufrufe, erscheint wie erwartet die „Welcome to nginx!“-Seite. Wenn ich die Subdomains aber mit HTTPS aufrufe, lande ich immer auf der WordPress-Seite - die eigentlich nur unter "dev2.domain.com" erreichbar sein sollte. Wenn die Webs aktiv sind, passiert das zum Glück nicht.


Ist das normal, warum ist das so? Kann ich das Abschalten?

PS: Installier nach dem "Perfect Server Tutorial", aber auf Debian 11. Für die WordPress Sete verwende ich diese nginx-Direktiven - hoffe das kommt nicht durch eine Falschkonfiguration:


Code:
location / {

try_files $uri $uri/ /index.php?$args;

}

rewrite /wp-admin$ $scheme://$host$uri/ permanent;

location ~*  \.(jpg|jpeg|png|gif|css|js|ico)$ {

expires max;

log_not_found off;

}
 

Till

Administrator
Ja, das ist das Standardverhalten des Apache und auch des Nginx web servers, wurde ja schon oft im Forum beschrieben. Es hat nichts mit ISPConfig zu tun.

Nein, dazu müsstest Du schon den Apache oder Nginx quellcode ändern. Aber Du kannst einen default vhost erstellen, der solche nicht zuzuordnenden requests auffängt so dass sie nicht bei der ersten webseite landen. Dazu musst Du eine webseite erstellen die immer erste im alphabet ist, also z.B. eine webseite mit der Domains '000default.tld'.
 

Edward

New Member
Ok danke für die Erklärung.
Ja tatsächlich, leider zu spät gesehen, wenn man "000default.tld ispconfig" googelt sieht man das diese Frage hier häufiger gestellt wurde. :confused:

Ich hätte noch eine andere Frage, die mich seit ein paar Stunden beschäftigt - vielleicht kann jemand was dazu sagen:

Ich wollte zum Test den ISPConfig Port ändern, von 8080 auf 57412. Hat auch funktioniert, aber trotzdem ist das Panel trotz Neustart des Servers immer auch noch unter 8080 erreichbar. Die ISPConfig Firewall ist aktiv und Port 8080 nicht offen, trotzdem zeigt mir netstat das:

user@dev1:/etc/nginx/sites-enabled# netstat -tulpn | grep nginx
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 695/nginx: master p
tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN 695/nginx: master p
tcp 0 0 0.0.0.0:8081 0.0.0.0:* LISTEN 695/nginx: master p
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 695/nginx: master p
tcp 0 0 0.0.0.0:57412 0.0.0.0:* LISTEN 695/nginx: master p
tcp6 0 0 :::80 :::* LISTEN 695/nginx: master p
tcp6 0 0 :::8080 :::* LISTEN 695/nginx: master p
tcp6 0 0 :::8081 :::* LISTEN 695/nginx: master p
tcp6 0 0 :::443 :::* LISTEN 695/nginx: master p
tcp6 0 0 :::57412 :::* LISTEN 695/nginx: master p


Ich habe /etc/nginx/sites-enabled/000-ispconfig.vhost editiert und den Port 8080 dort dreimal ersetzt, ist das überhaupt richtig? Alle Anleitungen die ich gefunden habe zum Web Console Port ändern wie diese hier beziehen sich auf Apache deshalb bin ich mir nicht ganz sicher.
 

Edward

New Member
Danke, anbei mal die Ausgabe:
user@dev1:/# grep -R -n 8080 /etc/nginx/
/etc/nginx/sites-enabled/000-ispconfig.vhost-BACKUP:2: listen 8080 ssl http2;
/etc/nginx/sites-enabled/000-ispconfig.vhost-BACKUP:3: listen [::]:8080 ssl http2 ipv6only=on;
/etc/nginx/sites-enabled/000-ispconfig.vhost-BACKUP:12: error_page 497 https://$host:8080$request_uri;

Ich werde jetzt die Firewall mal deaktivieren, bisschen warten, wieder aktivieren und den Server komplett neustarten. Ich glaube die Firewallregeln werden nicht übernommen.

Nachtrag: Hat funktioniert. :) ISPConfig 3 verwendet ja UFW als Firewall-Oberfläche für iptables, ich habe iptables-persistent installiert und hier steht das dies Konflikte geben könnte. Vielleicht lag es ja daran, an der Konfiguration habe ich nichts mehr geändert.
 
Zuletzt bearbeitet:

Werbung

Top