Bind queries logs

cocoon

New Member
Hallo zusammen,

versuche gerade auf meiner bind Umgebung, die eigentlich gut funktioniert, zu eruieren warum eine gTLD Domain nicht richtig auflöst wird.

Anfragen auf Domains die ich besitze werden durch den ISP und den entsprechenden Einträgen im Registrar, an meine DNS Server delegiert.

Um das Log zu aktivieren habe ich im named.conf.log folgende Änderungen eingepflegt:

logging {
channel bind_log {

severity debug 3;

};
….
category queries { bind_log; };
...
};


systemctl restart bind9.service
rndc querylog
rndc status

query logging is ON


Was mich nun ein wenig verwirrt ist das im bind log nur lokale IP Adressen von Clients finde und keine Public IP von Clients wenn eine spezifische Abfrage auf einer meiner Domain mache.

dig @Mein_NS_Server_Lokale_IP meine.domain à funktioniert wie erwarted
dig @Mein_NS_Server_Public_IP meine.domain à funktioniert NICHTwie erwarted

Ich gehe doch davon aus das wen ich das log freischalte, das alles angezeigt wird egal ob lokale oder public queries, oder was mach ich da falsch?

Danke
 

Till

Administrator
In vielen Fällen blockieren Router Anfragen die von intern kommen und an die public IP gehen, von daher kann es sein dass einfach Dein Test falsch ist. Du müsstest zum richtigen testen von einem externen system das nicht im lokalen Netzwerk ist anfragen.

Was mich nun ein wenig verwirrt ist das im bind log nur lokale IP Adressen von Clients finde und keine Public IP von Clients wenn eine spezifische Abfrage auf einer meiner Domain mache.
Wenn Du hinter einem Router bist via NAT, dann wird Dein System auch nur die interne IP sehen und loggen und nicht die externe. Von daher kann das so schon alles ok sein.
 

cocoon

New Member
Wenn Du hinter einem Router bist via NAT, dann wird Dein System auch nur die interne IP sehen und loggen und nicht die externe. Von daher kann das so schon alles ok sein.
befinde mich schon hinter einem Router/Firewall ist jedoch ein Source NAT.

Nichts destro trotz wenn ich ein Lokaler dig @Mein_NS_Server_Lokale_IP meine.domain --> funktioniert wie erwarted und ich sehe auch log einträge.

Wenn von Public her einen dig @Mein_NS_Server_Public_IP meine.domain --> funktioniert NICHT wie erwarted und ich sehe auch keine log einträge
 

cocoon

New Member
ich habe die root hints neu eingelesen von 2016021701 nach 2022083101, verhält sich noch gleich.

von public her
dig @Mein_NS_Server_Public_IP meine.domain

; <<>> DiG 9.16.1-Ubuntu <<>> @Mein_NS_Server_Public_IP meine.domain
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 6980
 

Till

Administrator
Hast Du denn mal geschaut ob BIND auch auf der richjtigen IP lauscht? Vielleicht hast Du ihn ja so konfiguriert dass er derzeit nur auf localhost lauscht. Oder Du hast den port in der Firewall des Servers geschlossen.
 

cocoon

New Member
Hast Du denn mal geschaut ob BIND auch auf der richjtigen IP lauscht? Vielleicht hast Du ihn ja so konfiguriert dass er derzeit nur auf localhost lauscht. Oder Du hast den port in der Firewall des Servers geschlossen.
Verstehe deine bedenken, jedoch erhallte ich von allen "andere.domains" die entsprechende antwort unabhäng davon ob ich die dig abfrage intern oder extern mache.

Nur bei der abfrage "meine.domain" ist die dig abfrage intern richtig, von extern wird sie refused.

Die domain kann ich gerne bei bedarf per pm mitteilen.

von public her
dig @Mein_NS_Server_Public_IP meine_andere.domain

; <<>> DiG 9.16.1-Ubuntu <<>> @Mein_NS_Server_Public_IP meine_andere.domain
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44657
 

Werbung

Top