Apache kommt nach ispconfig_update.sh nicht mehr hoch

kugman

New Member
Hallo zusammen,

Ich wünsch euch allen noch ein gutes neues Jahr!

ich hatte das Problem nach dem letzten Update auch schon. Hier hat mir dann dieser Thread weitergeholfen:
[SOLVED] Problem nach Update auf 3.1.15p3 | Howtoforge - Linux Howtos und Tutorials

Jetzt hilfts mir allerdings nicht weiter. Ich habe einfach ispconfig_update.sh aufgerufen und alles im default durchgeklickt.
Bash:
Updating Crontab
Restarting services ...
Job for apache2.service failed because the control process exited with error cod                                                                                                       e.
See "systemctl status apache2.service" and "journalctl -xe" for details.
Update finished.

Code:
root@web01:~# systemctl status apache2.service
● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2021-01-09 18:42:42 CET; 2min 49s ago
  Process: 29289 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)

Jan 09 18:42:42 web01 systemd[1]: Starting The Apache HTTP Server...
Jan 09 18:42:42 web01 apachectl[29289]: AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.vhost:7
Jan 09 18:42:42 web01 apachectl[29289]: AH00526: Syntax error on line 155 of /etc/apache2/sites-enabled/100-catb.maku-test.de.vhost:
Jan 09 18:42:42 web01 apachectl[29289]: SSLCertificateFile: file '/var/www/clients/client1/web5/ssl/catb.maku-test.de-le.crt' does not exist or is empty
Jan 09 18:42:42 web01 apachectl[29289]: Action 'start' failed.
Jan 09 18:42:42 web01 apachectl[29289]: The Apache error log may have more information.
Jan 09 18:42:42 web01 systemd[1]: apache2.service: Control process exited, code=exited status=1
Jan 09 18:42:42 web01 systemd[1]: Failed to start The Apache HTTP Server.
Jan 09 18:42:42 web01 systemd[1]: apache2.service: Unit entered failed state.
Jan 09 18:42:42 web01 systemd[1]: apache2.service: Failed with result 'exit-code'.
Code:
-- Subject: Unit apache2.service has begun start-up
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit apache2.service has begun starting up.
Jan 09 18:47:56 web01 apachectl[29620]: AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.vhost:7
Jan 09 18:47:56 web01 apachectl[29620]: AH00526: Syntax error on line 155 of /etc/apache2/sites-enabled/100-catb.maku-test.de.vhost:
Jan 09 18:47:56 web01 apachectl[29620]: SSLCertificateFile: file '/var/www/clients/client1/web5/ssl/catb.maku-test.de-le.crt' does not exist or is empty
Jan 09 18:47:56 web01 apachectl[29620]: Action 'start' failed.
Jan 09 18:47:56 web01 apachectl[29620]: The Apache error log may have more information.
Jan 09 18:47:56 web01 systemd[1]: apache2.service: Control process exited, code=exited status=1
Jan 09 18:47:56 web01 systemd[1]: Failed to start The Apache HTTP Server.
-- Subject: Unit apache2.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit apache2.service has failed.
--
-- The result is failed.
Jan 09 18:47:56 web01 systemd[1]: apache2.service: Unit entered failed state.
Jan 09 18:47:56 web01 systemd[1]: apache2.service: Failed with result 'exit-code'.

Wer kann mir hier bitteschön weiterhelfen?

vielen Dank,

Gruß, Markus
 

Till

Administrator
Scheinbar hast Du ein ssl cert manuell entfernt, alsoe entweder die Datei gelöscht oder es per certbot befehl gelöscht:

SSLCertificateFile: file '/var/www/clients/client1/web5/ssl/catb.maku-test.de-le.crt' does not exist or is empty

Durch das fehlende cert, kann apache nicht mehr starten. Entferne den symlink zum vhost manuall aus /etc/apache2/sites-enabled/ bzw. aus /etc/nginx/sites-enabled/
 

kugman

New Member
Hallo Till

danke für deine Antwort.
nee hab ich nicht. Die Zertifikate sind alle an Ort und Stelle. Wenn ich den symlink entferne meckert er das nächste Zertifikat an. So lange bis alle Zertifikate entfernt sind. Aber dann kommt er dennoch nicht hoch.
 

Till

Administrator
Erhältst Du denn das Zertifikat ausgegeben, wenn Du:

cat /var/www/clients/client1/web5/ssl/catb.maku-test.de-le.crt

auf der Shell ausführst? Der Pfad /var/www/clients/client1/web5/ssl/catb.maku-test.de-le.crt ist ja ein symlink auf das LE ssl cert in /etc/letsencrypt/..... Irgend was passt da vermutlich in /etc/letsencrypt/..... nicht.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.